欢迎来到 Android人的问与答 ,在这里提问或帮助他人解答。 Question2Answer的1.6.x和1.7.x版本的中文翻译包我修改更新:

Question2answer

如何使用中文语言包

Q2A 1.6.x - Chinese Simplified (简体中文)

Q2A 1.7.x - Chinese Simplified (简体中文)


国内服务器推荐 阿里云服务器
国外服务器推荐 DigitalOcean
VPN推荐 正版Green VPN
阿里云推荐码:ldvq50

@Override must override a superclass method 问题解决

0 喜欢 0 不喜欢
119 浏览

1.Java开发环境时

如果在使用Eclipse开发Java项目时,在使用 @Override 出现以下错误:

The method *** of type *** must override a superclass method

 

主要是因为你的Compiler是jdk5,(5不支持@Override等形式的批注)只要把它改为6就可以了。

方法:将window->preferences->java-compiler中的Compiler compliance level修改为6.0。

 

2.Android开发环境时

有时候从已有Android工程导入到Eclipse后,编译会报这个错误。

这时候需要在工程上右键,->Properties->Java Compiler(Left panel)->Compiler compliance level修改到相应版本,比如1.6之类(如果1.7时编译出错)。

最新提问 1月 18, 2015 分类:Java基础 | 用户: forlong401 (7,050 分)

登录 或者 注册 后回答这个问题。

...