欢迎来到 Android人的问与答 ,在这里提问或帮助他人解答。 Question2Answer的1.6.x和1.7.x版本的中文翻译包我修改更新:

Question2answer

如何使用中文语言包

Q2A 1.6.x - Chinese Simplified (简体中文)

Q2A 1.7.x - Chinese Simplified (简体中文)


国内服务器推荐 阿里云服务器
国外服务器推荐 DigitalOcean
VPN推荐 正版Green VPN
阿里云推荐码:ldvq50

在Eclipse中将Android development tools升级到v23后各种错误

0 喜欢 0 不喜欢
195 浏览

当你更新Eclipse的SDK tools 到(rev 23) ,重启Eclipse后,会报下面的错误::

This Android SDK requires Android Developer Toolkit version 23.0.0 or above. Current version is 22.6.3.v201404151837-1123206. Please update ADT to the latest version.
但是你去更新"Check for updates"的话,又说没有新的了。如果你去"Install new software",你能找到version 23,但你不能更新,因为又报下面的错误:
Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once:
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

 

这个错误产生的原因是ADT v23.0.0自身的bug。后来谷歌释放ADT v23.0.2来修复v23.0.0的bug。所以,

解决的办法呢,就是装ADT v23.0.2版本啦。步骤如下:

步骤1:Eclipse的Help -> Install New Software...

步骤2:"Work with",选择Android source https://dl-ssl.google.com/android/eclipse ,add以后选择Android source
Tick ADT v23.0 for installation, 然后一路next。

步骤3:Eclipse会提示"Install Remediation Page",说是有一个和前版本冲突的问题。然后选择 "Update my installation to be compatible with items being installed" 去卸载老版本并安装新版本。然后就是原来的通用步骤了。

 
最新提问 12月 31, 2014 分类:Android SDK | 用户: forlong401 (7,050 分)

登录 或者 注册 后回答这个问题。

...